Deeplinking questions


#1

How do I add Mapbox with my API-key to my URL?

https://www.routexl.com/?q=49.275099,-122.992882,Location1$49.279984,-122.987564,Location2$49.279984,-122.987564,Location3$49.218158,-122.967696,Location4$49.22202,-123.002,Location5$49.208853,-122.923708,Location6$49.211319,-122.899849,Location7$49.2193291,-122.9575407,Location8$49.258546,-123.133863,Location9$49.208254,-123.127662,Location10$

Also getting problem in lower right hand side with " Searching addresses: 1 " with spinning circle. And clicking Find Route does nothing. My addresses are on the map.

Tried changing the URL to use the .nl site. I can get it to give the route but one of addresses was listed as the east coast of USA listed as “49.22202,-123.002,HMLK-3122 Canada, Kentucky, United States”. It seems to be confused about the 3rd entry being the Label?


Addresses not found
#2

Your post was moved to a new topic.

Indeed, there seems to be an issue with your URL. We’ll have to look into that in more detail. We’ll come back to that.

As to adding a preferred geocoder and an API key to an URL, that is not possible. Make sure to be logged in and deeplink to the .nl site to use your settings as saved in the Options dialog.

If you wish to import labels, you can use the same format for importing additional fields.


#3

I have never used @LocationName@ before. Is that what I need to do? I use an Excel spreadsheet to build the URL so it is easy to try different locations. I already experienced the Google Static Maps not being free and switched to Mapbox.

I changed my waypoints to other locations and it worked fine.


#4

Yes, to import names/labels you use the @ signs.

If it does not work, try to urlencode the input, e.g. replace the @'s with %40.


#5

With regard to the other issue, coordinates must have a precision of at least 4 decimal places (e.g. 0.1234) to be recognized during import. We’ve updated the user manual for that.