The Underlying Connection Was Closed


I have sent a request to the API and i receive the " The Underlying Connection Was Closed " exception. My client received the same result on a different network and internet connection.

The inner exception is as follows,

Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.

Can someone point me to why this is occurring, as it has been working for ages and we have a paid account that is up tom date.

the request was to endpoint

with my credentials used to log into this account and the addresses to router are below.


Your account seems fine indeed. If it always worked until a few days, the first thing we’d check is the version of the TLS protocol your software is using.

See: Protocol TLS 1.2


Thank you for your response. I have changed the tls version to 1.2, now the response is returning a 409 Conflict exception.

endpiont is -
collection of address locations is - [{“address”:“323180”,“lat”:"-37.8231278",“lng”:“144.9648298”}]"

Exception Message = The remote server returned an error: (409) Conflict

You’ll probably get this response because there are too little locations in the input. Only one location does not make sense to the routing algorithm. Try again with some more.