Filemaker - No input found:


#1

Hello, I’ve been trying to use cURL option in Insert from URL, and I don’t understand why I’m not getting any valid responses…

Here are the options/configurations that I used:

URL: “https://api.routexl.com/v2/tour/
cURL options: “-u hyunmin85:password -X POST locations=[{“address”:“The Hague, The Netherlands”,“lat”:“52.05429”,“lng”:“4.248618”},{“address”:“The Hague, The Netherlands”,“lat”:“52.076892”,“lng”:“4.26975”},{“address”:“Uden, The Netherlands”,“lat”:“51.669946”,“lng”:“5.61852”},{“address”:“Sint-Oedenrode, The Netherlands”,“lat”:“51.589548”,“lng”:“5.432482”}]”

I’ve also tried the following options:

“-u hyunmin85:password -data ‘locations=[{“address”:“The Hague, The Netherlands”,“lat”:“52.05429”,“lng”:“4.248618”},{“address”:“The Hague, The Netherlands”,“lat”:“52.076892”,“lng”:“4.26975”},{“address”:“Uden, The Netherlands”,“lat”:“51.669946”,“lng”:“5.61852”},{“address”:“Sint-Oedenrode, The Netherlands”,“lat”:“51.589548”,“lng”:“5.432482”}]’”

“-u hyunmin85:password -X POST ‘locations=[{address:The Hague, The Netherlands,lat:52.05429,lng:4.248618},{address:The Hague, The Netherlands,lat:52.076892,lng:4.26975},{address:Uden, The Netherlands,lat:51.669946,lng:5.61852},{address:Sint-Oedenrode, The Netherlands,lat:51.589548,lng:5.432482}]’”

“-u hyunmin85:password -X POST locations=[{address:The Hague, The Netherlands,lat:52.05429,lng:4.248618},{address:The Hague, The Netherlands,lat:52.076892,lng:4.26975},{address:Uden, The Netherlands,lat:51.669946,lng:5.61852},{address:Sint-Oedenrode, The Netherlands,lat:51.589548,lng:5.432482}]”

“-u hyunmin85:password \ -d ‘locations=[{“address”:“The Hague, The Netherlands”,“lat”:“52.05429”,“lng”:“4.248618”},{“address”:“The Hague, The Netherlands”,“lat”:“52.076892”,“lng”:“4.26975”},{“address”:“Uden, The Netherlands”,“lat”:“51.669946”,“lng”:“5.61852”},{“address”:“Sint-Oedenrode, The Netherlands”,“lat”:“51.589548”,“lng”:“5.432482”}]’”

None of them seem to work… please help!!!


#2

Insert from URL seems to be FileMaker Pro function and we have no experience with that. But looking at the input, the first thing that we see are the curly quotes. We’d try to replace the curly quotes characters “ ” in the locations array with straight quotes " ".


#3

The curly quotes were automatically formatted when i copied and pasted onto the forum. They are actually straight quotes in Filemaker. Is there anything else I’m missing in cURL options? Did I format it correctly if it were text-only interface? I know Filemaker is compatible with cURL protocols…


#4

Ok, sorry for that. Luckily, FileMaker has a free trial. We installed that and got the Insert from URL to work with these cURL options:

"-u user:password" &
" -X POST" &
" -d locations=[{\"address\":\"The%20Hague,%20The%20Netherlands\",\"lat\":\"52.05429\",\"lng\":\"4.248618\"},{\"address\":\"The%20Hague,%20The%20Netherlands\",\"lat\":\"52.076892\",\"lng\":\"4.26975\"},{\"address\":\"Uden,%20The%20Netherlands\",\"lat\":\"51.669946\",\"lng\":\"5.61852\"},{\"address\":\"Sint-Oedenrode,%20The%20Netherlands\",\"lat\":\"51.589548\",\"lng\":\"5.432482\"}]" &
" --header \"Content-type: application/x-www-form-urlencoded\""

So, we specified the POST request, slashed the quotes and urlencoded spaces in the locations JSON array, and set the content type. There may be better solutions, but as said we’re no FileMaker users.


#5

It works! Thank you so much. Ill be able to take care of it from here. Thanks for the speedy support!