Error setting certificate verify locations CAfile: cacert.pem CApath: none


#1

One week ago I was add the code in PHP  to use a RouteXL  100 Month and all works well, now I check again and the same code return the error code:

error setting certificate verify locations:  CAfile: C:\Program Files (x86)\Parallels\Plesk\Additional\PHPSettings\cacert.pem
  CApath: none ] : 

The subscription ends tomorrow May/07/2017, can be this the problem ?
What I must do? Do you can help me with this error ?


#2

Thank you for sharing the solution!


#3

I solved it with this link:

https://support.plesk.com/hc/en-us/articles/213909205-Websites-are-unable-to-make-php-curl-requests-…

say this:

Download the cacert.pem file from the main curl website http://curl.haxx.se/ca/cacert.pem .

Add the following into php.ini or add into ‘Additional directives’ under Websites & Domains > PHP settings :

curl.cainfo=full\path\to\cacert.pem