Deeplink with authentification

Hey there,

I’d like to link my application to RouteXL via your deeplink. But as I have to import many locations, I tend to exeed the free user’s limit. How can I make sure to be logged in when I’m using your deeplink?

There is no method to log in with the deeplink. You should be logged in before opening the deeplink.

To log in immediately when opening the the browser window, load it with this URL:

Thank you for your answer, but this didn’t solve my problem so far. But after a little research if found the solution to my problem by myself that might be interesting for you.

I used the deeplink according to your example on the wiki page. But as your log in dialog is always redirecting to your domain, one cannot use other tlds that you provide - like .com or .de The reason might be probably your log in cookie that is only valid for

To make it easier for other users you might change your deeplink URL example on your wiki page from… to

Thank you for sharing your solution and the suggestion for the wiki page. We have made the change and added the language parameter to have the page translation default to English.

I’m also trying to use this workaround, however my link doesn’t redirect to the deeplink. It redirects to

for some reason my link is formatted differently on this forum, its encoded the way it should be however it doesn’t show it that way here.

This is an older thread, meanwhile we’ve changed our main domain to, so wherever it says .nl change that to .com

Thank you, redirecting works now, however, the redirection partially decodes my URL. Now it doesn’t work anymore…

The $ used to seperate adresses doesn’t seem to be decoded properly, it just disappears. Any workaround for this? The same happens to the {} markers to add comments…

The problem is that are two parts that need to be urlencoded.

First, the redirection URL after login. That is everything after ?redirect_to=

Second, the locations that need to be mapped after redirection. That’s everything after ?q=

Combining this, the second part needs to be urlencoded twice. For example, a space %20 becomes %2520. In your case:

This also doesn’t seem to work, I don’t see why though.

Because URL’s get malformed by the forum software. We’ve changed the formatting now. Just copy the URL and paste in the browser address bar.

Works now! Thanks for your explanation, my deeplink is generated by a own written PHP script, I’ll just have to tweak my code now so my URL gets decoded twice.

1 Like