API - Unauthorized Returned


#1

Hello, it appears API calls are also returning Unauthorized today after the communication problems. Can you advise if this is being worked on or do we need to recreate accounts?


#2

Correct, this still does not seem fixed. Any updates ? We are using this in a critical production server. Need to get this working ASAP.


#3

We’ve restored the service and are investigating the issue.


#4

Hey folks

This is occurring again as of 3.50pm BST. Do we know what the problem is? I’ve a client needs to run daily job sheets at this time of day and it can be done manual and optimised later, but confidence is king…

Thanks


#5

The problem seems to have been a server setting that was changed last night. It was tested, but on live disabled the authentication system with some delay. We’d rather not disclose all details for reasons of security.

We solved the problem this morning and prevented it will occur again. If you are getting 403 errors at this moment, you may want to double check your credentials.


#6

Still getting 401s not 403s (unfortunately!)

Error:RouteXL\API_Connector Object ( [result] => [http_code] => 401 [error] => )

I’m using V2 of the API if that makes any difference


#7

There are error messages for invalid passwords in our logs for both accounts on your IP. Can you double check your credentials? If needed, you may reset your password here.


#8

Thank you. I seem to have access again, but it hasn’t seemed to be acting consistently. Today’s job is done will check back in tomorrow + test everything again.