Addresses coming up three random words

Once I import all addresses required for my route and route it out, the addresses come up three random words. Makes it extremely difficult to figure out. Also it is not optimized half of the time. Since I pay for the software I would expect to receive the product I pay for, I’m currently not getting that. May cancel subscription.

To prevent your addresses to be translated to What3words (w3w) addresses, set Options > Geocoding > Add alternative address to “No”

Routes should always be optimized unless you disable Options > Routing > Optimize route. If you have issues with that, please share the route with us so we can check.